GRAVITSAPA.INFO

Компьютеры, электроника, софт, авто, мото, вело, сайты, жизнь, советы :)

GRAVITSAPA.info - интересный блог

Блокируем рекламу с помощью роутера Mikrotik работающего на RouterOS

2003 просмотров Интернет 3 комментария » 26 Июн 2019

Если используете дома, в офисе или ещё где либо маршрутизатор Mikrotik, то есть простой и действенный способ блокировки рекламы в сети создаваемой самим роутером. Т.е. при подключении к интернету по WiFi или кабелем к Mikrotik будет блокироваться реклама и нежелательный входящий трафик.

Способ не гарантирует 100% блокировку рекламы, но при этом не нагружает маршрутизатор, поэтому отлично подойдёт даже для бюджетных устройств, например MikroTik hAP lite classic (RB941-2nD).

Как блокировать рекламу и нежелательный входящий трафик через Mikrotik?

Зайдите в интерфейс управления RouterOS (лучше всего через Winbox, но можно и просто в браузере по адресу 192.168.88.1).
Откройте терминал, вставьте код ниже:

/system script
add name=adblock policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":\
log warning \"starting adblock update\";\r\
\n\
\n\
\n:delay 20;\r\
\n\
\n\
\n:log warning \"downloading adblock\";\r\
\n\
\n\
\n\
\n\
\n:local hostScriptUrl \"https://www.micu.eu/adblock/adblock_lite.php\";\
\n\
\n\
\n\
\n\r\
\n:local scriptName \"adblock\";\
\n\
\n\
\n\
\n\r\
\ndo {\
\n\
\n /tool fetch mode=http url=\$hostScriptUrl dst-path=(\"./\".\$scriptName\
);\
\n\
\n\r\
\n:delay 20;\
\n\
\n\r\
\n:if ([:len [/file find name=\$scriptName]] > 0) do={\r\
\n\
\n\
\n :log warning \"removing old adblock list\";\
\n\
\n\r\
\n /ip dns static remove [/ip dns static find address=127.0.0.1];\
\n\
\n\r\
\n :log warning \"importing new adblock list\";\r\
\n\
\n\
\n /import file-name=\$scriptName;\r\
\n\
\n\
\n /file remove \$scriptName;\r\
\n\
\n\
\n :log warning \"adblock list imported\";\r\
\n\
\n\
\n } else={\
\n\
\n \r\
\n:log warning \"adblock list not downloaded, script stopped\";\r\
\n\
\n\
\n }\r\
\n\
\n\
\n} on-error={\
\n\
\n \r\
\n:log warning \"adblock list download FAILED\";\
\n\
\n\r\
\n};"
/system scheduler
add interval=1d name=adblock on-event=adblock policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup
add name=adblock_startup on-event=\
":delay 30;\r\
\n/system script run adblock" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup

Тут же в терминале запустите код разрешающий роутеру DNS запросы:

/ip firewall nat
add action=redirect chain=dstnat dst-port=53 in-interface=bridge protocol=udp

Уставите DNS роутера его собственный IP как на скриншоте ниже:

На этом всё 😉 Проверяйте, там где чаще всего появлялась реклама её быть не должно. К тому же реклама возможно будет блокироваться в приложениях на мобильных устройствах, а так же на телевизорах со SmartTV.

Оставь свой коммент

3 комментария к посту “ Блокируем рекламу с помощью роутера Mikrotik работающего на RouterOS”:

  1. Egor

    В рамках данной публикации мне хотелось бы поговорить об одном из методов обхода блокировки сайтов со стороны провайдера на маршрутизаторах Mikrotik под управлением RouterOS.

  2. patriot2101

    Добрый день! Хотелось бы внести некоторые изменения, чтобы планировщик работал корректно, так как данная команда ничего не выполняет
    /system scheduler
    add interval=1d name=adblock on-event=adblock policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-time=startup
    её необходимо заменить на следующий вид:
    /system scheduler
    add interval=1d name=adblock on-event=/system script run adblock policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-time=startup

NIGHT
Наверх